linux软件安装包依赖问题

当我首次使用pwndbg的heap指令的时候:
image-20220901192451610

说是缺少依赖,需要我安装一些库文件

但是当我去安装这些库的时候却发生了依赖冲突
image-20220901192638567

发现,是我的libc6,太新了,需要安装回旧版本的库

1
sudo apt-get install  libc6=2.31-0kylin9.2

安装完旧版本的库后,就能安装 libc6-dbg 啦!
image-20220901192829669

再去 heap,就能看到信息了
image-20220901193217714

参考:查看指定软件所有版本